Results 1 to 6 of 6

Thread: Rimset Compur B and T Not Working

  1. #1

    Join Date
    Jun 2012
    Location
    Gibsons BC Canada
    Posts
    44

    Rimset Compur B and T Not Working

    Hi,

    I have a Carl Zeiss Tessar Jena 135 mm lens in rim-set compur shutter where the B & T settings will not cock. All the other shutter settings seem fine. When I try to cock the T & B, it will only go so far before it returns, all the while sounding like its firing. Anyone know what might be the possible cause and repair?

    Brian
    Last edited by henseman; 31-Jan-2013 at 05:50. Reason: made a mistake on identifying proper lens

  2. #2

    Join Date
    Oct 2010
    Posts
    3,326

    Re: Rimset Compur B and T Not Working

    On my rim-set Compur there's no need to cock the shutter for the B and T settings. Just use the shutter release lever (or cable release) to open and close the shutter.

    Jonathan

  3. #3

    Join Date
    Jun 2012
    Location
    Gibsons BC Canada
    Posts
    44

    Re: Rimset Compur B and T Not Working

    Jonathan, thank you .......I should have checked online for the proper use of the lens. I have had it in my possession for quite some time as it came with an old Century Graphic and I never got round to using it. I'm not up on all the mechanics of using old lenses.

    A friend checked it over and says he found a bent lever inside that may have prevented the shutter from cocking even when using a cable release. He's dropping it off later today and I'll let you know if he managed to fix it.

    Brian

  4. #4

    Join Date
    Jun 2012
    Location
    Gibsons BC Canada
    Posts
    44

    Re: Rimset Compur B and T Not Working

    Hi Jonathan,

    My friend found/fixed the problem and the lens now works well.

    Brian



    Quote Originally Posted by henseman View Post
    Jonathan, thank you .......I should have checked online for the proper use of the lens. I have had it in my possession for quite some time as it came with an old Century Graphic and I never got round to using it. I'm not up on all the mechanics of using old lenses.

    A friend checked it over and says he found a bent lever inside that may have prevented the shutter from cocking even when using a cable release. He's dropping it off later today and I'll let you know if he managed to fix it.

    Brian

  5. #5

    Join Date
    Oct 2010
    Posts
    3,326

    Re: Rimset Compur B and T Not Working

    Good to hear! Happy shooting.

    Jonathan

  6. #6

    Re: Rimset Compur B and T Not Working

    Thank God for this thread! I just acquired a 10,5cm Tessar and I too was surprised that I could not cock the shutter for T or B.
    Not having to do it is actually fantastic, much more usable than modern lenses where you do need to have the shutter in tension for T or B.
    Does anyone know why they have stopped making shutters with this very useful feature?

Similar Threads

  1. Getting to 1/400 on old Linhof Compur Rimset Shutters?
    By Frank Petronio in forum Lenses & Lens Accessories
    Replies: 8
    Last Post: 17-May-2010, 11:42
  2. Compur 0 shutter not working on B
    By Steve Block in forum Cameras & Camera Accessories
    Replies: 11
    Last Post: 8-Oct-2007, 15:27
  3. WTB: Working 5x7'' set
    By robertu in forum Cameras & Camera Accessories
    Replies: 20
    Last Post: 15-Sep-2007, 07:31
  4. Whats the diff between a Compur & a Syncro-Compur
    By Bill Brady in forum Lenses & Lens Accessories
    Replies: 4
    Last Post: 10-Nov-2000, 08:05

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •