Results 1 to 6 of 6

Thread: Brass Lens Front Element is loose / Need help

  1. #1

    Join Date
    Mar 2019
    Posts
    60

    Brass Lens Front Element is loose / Need help

    Hello guys, I bought a beautiful Kranz Petzval lens at an auction. But the front glass element is loose.

    Maybe I can glue it to the brass mounting, because there is no other way to mount it. No thread like in other lenses.

    Maybe you can help me to find a good way to fix this problem. Is there a glue that is good for mounting glass on brass? It should be very solid.

    Yes it´s not a adequate way, but I wanna keep it for a lifetime.

    I am thankful for everykind of help or tip

  2. #2

    Join Date
    Sep 2007
    Location
    AZ
    Posts
    4,417

    Re: Brass Lens Front Element is loose / Need help

    If you can show some pictures, we can help. Some lens fixtures have a rolled edge, some have a screw in ring, to hold the glass in.

  3. #3

    Join Date
    Mar 2019
    Posts
    60

    Re: Brass Lens Front Element is loose / Need help

    Click image for larger version. 

Name:	Foto 06.11.20, 16 54 16.jpg 
Views:	25 
Size:	38.2 KB 
ID:	209236Click image for larger version. 

Name:	Foto 06.11.20, 16 54 25.jpg 
Views:	25 
Size:	79.1 KB 
ID:	209237Click image for larger version. 

Name:	Foto 06.11.20, 16 54 34.jpg 
Views:	26 
Size:	48.3 KB 
ID:	209238

    There was this small brass wire t hold the lens... but it was loose and broke off...

  4. #4

    Join Date
    Mar 2019
    Posts
    60

    Re: Brass Lens Front Element is loose / Need help

    Click image for larger version. 

Name:	Foto 06.11.20, 16 55 18.jpg 
Views:	32 
Size:	86.0 KB 
ID:	209239

    This is the wire

  5. #5

    Join Date
    Dec 2005
    Location
    Los Angeles, CA
    Posts
    5,242

    Re: Brass Lens Front Element is loose / Need help

    That, quite possibly, is a rolled over edge that failed.

  6. #6

    Join Date
    Jan 2009
    Location
    Denmark
    Posts
    6,124

    Re: Brass Lens Front Element is loose / Need help

    Agreed. I am surprised Kranz used this system. Damage always happens when amateurs like us try to raise the edge, especially when this is the third time it has been done (for rebalsaming every 75 years) since the mid 1800’s.
    I have struggled with this mount system many times when changing the balsam and have used ordinary window sealer at the base (very small quantities) when the turnover is compromised. Obviously, the seal has to checked occasionally.

    It could also be a primitive “locking ring” pushed into the thread which accepted the screw in mounting ring (lost years ago!

Similar Threads

  1. Verito 6 1/8 inch lens with fungus in front element
    By Simon Benton in forum Lenses & Lens Accessories
    Replies: 8
    Last Post: 22-Apr-2018, 15:37
  2. Schneider 360 f6.8 Symmar S front element loose
    By brighamr in forum Lenses & Lens Accessories
    Replies: 4
    Last Post: 10-Jan-2009, 15:02
  3. Polishing front element of Goerz lens
    By Steve Sherman in forum Lenses & Lens Accessories
    Replies: 4
    Last Post: 17-Mar-2002, 12:37
  4. Use the front or back element of a Symmar lens separately
    By chin-fan so in forum Lenses & Lens Accessories
    Replies: 14
    Last Post: 12-Nov-2001, 11:46

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •