Results 1 to 7 of 7

Thread: Ilford Multigrade 500h Help - Left light no longer turns on!

  1. #1

    Ilford Multigrade 500h Help - Left light no longer turns on!

    Hello, I have an Ilford Multigrade system on a de vere 504, with an RH Designs analyser pro timer.

    Earlier today I went to print and just as I turned on the focus the left hand bulb blew. I replaced the bulb with a new one, but now the left hand light in the head of the enlarger doesn't turn on at all! and I'm at a complete loss as to what to do.

    I have tested the bulb in the right hand side, and it definitely works.

    I have tried a separate power supply (500s, as I have a spare), and it is the same.

    I've also tried the ilford timer instead of the analyser pro, and that too doesn't make any difference - basically only the magenta light (the right hand side) turns on. The left hand light which normally gives the yellow light, won't turn on at all.

    I have no idea what the problem might be, or how to repair it, and am quite upset as I use the enlarger a lot.

    does anyone know what the problem might be? any help or advice would be greatly appreciated!

  2. #2

    Re: Ilford Multigrade 500h Help - Left light no longer turns on!

    Just to Update, i just had another look and tried to clean the ceramic bulb holder again and have managed to get it working! i think it was either some dirt causing a bad contact or that I was not pushing the new bulb into the holder far enough. So its all ok now thank goodness, and fingers crossed! So sorry for this unnecessary thread.

  3. #3
    Tin Can's Avatar
    Join Date
    Dec 2011
    Posts
    14,724

    Re: Ilford Multigrade 500h Help - Left light no longer turns on!

    Don't be sorry

    Be happy, sometimes we need to talk/write out loud

    Good news!
    sin eater

  4. #4

    Re: Ilford Multigrade 500h Help - Left light no longer turns on!

    Hi, thanks for the kind words, I am so happy!! i dont know what i would have done if i couldnt get it working again, being able to print on that enlarger is a major part of my life right now, so I am very relieved

  5. #5

    Join Date
    Dec 2014
    Location
    Iowa City, Iowa
    Posts
    1,155

    Re: Ilford Multigrade 500h Help - Left light no longer turns on!

    The Beseler Universal head has the crappy pin sockets on the lamps. They are a pain. These things should be gold plated.

  6. #6
    Barry Kirsten's Avatar
    Join Date
    Oct 2010
    Location
    Brookfield, Vic., Aust.
    Posts
    497

    Re: Ilford Multigrade 500h Help - Left light no longer turns on!

    These Multigrade heads are getting pretty old now and seem prone to problems which may be hard to find. Last year my 500H started playing up and I couldn't find what was causing it not to work. I checked all the obvious things like connectors, but all seemed to be OK. I passed it on to a friend of a friend who was able to find a loose connector in the controller. It tricked me, but it's thankfully been perfect ever since. (Fingers crossed.)

  7. #7

    Join Date
    Dec 2014
    Location
    Suwanee, GA
    Posts
    589

    Re: Ilford Multigrade 500h Help - Left light no longer turns on!

    Quote Originally Posted by forgetmenot77 View Post
    Just to Update, i just had another look and tried to clean the ceramic bulb holder again and have managed to get it working! i think it was either some dirt causing a bad contact or that I was not pushing the new bulb into the holder far enough. So its all ok now thank goodness, and fingers crossed! So sorry for this unnecessary thread.
    There is a vendor on ebay that refurbishes these heads. I have found I need to give it a good cleaning every 6 months or so. The power unit also needs to be cleaned from dust annually to keep it working well. Even the RH analyzer seems to get buggy if I let it sit too long.
    Adventure is worthwhile in itself. ... Never interrupt someone doing what you said couldn't be done. -- Amelia Earhart
    http://www.searing.photography

Similar Threads

  1. Ilford Multigrade 500H Fan Issue
    By fineartphotoz in forum Darkroom: Equipment
    Replies: 10
    Last Post: 21-Jun-2020, 05:57
  2. ilford 500h multigrade head cooling fan question
    By zsolt in forum LF DIY (Do It Yourself)
    Replies: 15
    Last Post: 28-May-2017, 03:36
  3. Ilford Multigrade 500H Head
    By Cornfield in forum Darkroom: Equipment
    Replies: 7
    Last Post: 17-Jun-2015, 06:48
  4. Ilford 500H Multigrade enlarger head - instructions
    By Leigh in forum Darkroom: Film, Processing & Printing
    Replies: 0
    Last Post: 13-Mar-2011, 16:30

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •