Results 1 to 3 of 3

Thread: HELP!!! 14" Veritar problem

  1. #1

    Join Date
    Dec 2009
    Location
    Saratoga Springs, NY, USA
    Posts
    793

    HELP!!! 14" Veritar problem

    I bought a 14" Wollensak Verito in great shape and I can't get the rear lens element and retaining ring off the shutter to mount it through the lens board. I had removed both one time, and they slid off easily, and very easily went back on with no forcing. So I'm kind of perplexed why it won't budge now.

    Anyway, what's a safe way to remove it without just applying brute force??? I'm wondering if perhaps the retaining ring is up against the rear element and needs to be moved the other way first....

    Click image for larger version. 

Name:	IMG_7108.jpg 
Views:	23 
Size:	42.5 KB 
ID:	194048
    David Aimone Photography
    Critiques always welcome...

  2. #2

    Join Date
    Dec 2009
    Location
    Saratoga Springs, NY, USA
    Posts
    793

    Re: HELP!!! 14" Veritar problem

    Fixed. Sorry 'bout the panic! Is there something I should use that is safe/proactively on threads to keep them from seizing in the future?
    David Aimone Photography
    Critiques always welcome...

  3. #3
    Mark Sawyer's Avatar
    Join Date
    Jul 2004
    Location
    Stuck inside of Tucson with the Eastern Seaboard Blues again...
    Posts
    5,572

    Re: HELP!!! 14" Veritar problem

    A very small amount of candle/bee's wax on the threads. Don't use oil, as that will haze the inside of the lens over time. Not a big deal as it cleans off, but still... And of course, don't torque it on too hard, just snug.
    "I love my Verito lens, but I always have to sharpen everything in Photoshop..."

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •