Results 1 to 5 of 5

Thread: CPP2 - Heating Element no longer heating

  1. #1

    Join Date
    Jul 2015
    Posts
    45

    CPP2 - Heating Element no longer heating

    So, today I set up the Jobo CPP2 for use and discovered the heating element is not working. I was under the impression that if the pump was working, then the heating element would heat simultaneously, but I guess not? Anyhow, I attempted to reset the fuse, but am unable to do so. Firstly, I think the assembly is somewhat loose as button seems to shift around a lot. Secondly, and this may seem daft, but how do I know if it's been successfully reset asides from waiting for the heating element to work.

    I've attached a cell phone picture of what I think the reset button is - can anyone just confirm that the specific button is the fuse? Again, the assembly is loose so there's a tendency for the fuse to shift around. Also, I could not find a white reset button - so the closest was silver, but may just be a machine screw and yet it depresses so I thought this could be it.

    Looking forward to your guys' thoughts and advice. Thanks for reading.

    Click image for larger version. 

Name:	05B7CUiBTg2GnWuu%kRv%A.jpg 
Views:	25 
Size:	29.2 KB 
ID:	192486

  2. #2

    Join Date
    Feb 2008
    Location
    The Highlands of Scotland
    Posts
    161

    Re: CPP2 - Heating Element no longer heating

    I'm sure i read on this (or another) forum that the reset button can seize open-circuit because of chemical attack/corrosion.

    The fix was to open the control unit and clean out the reset switch with contact cleaner or similar until it functioned properly.

    Of course, do not try this if you are not comfortable working with electrical devices.

    Mike

  3. #3

    Join Date
    Jul 2015
    Posts
    45

    Re: CPP2 - Heating Element no longer heating

    Thanks for your help. Somehow, the assembly itself shook loose and was not in the guides. I reset the fuse and it reheats fine now. Appreciate everyone's advice!

  4. #4

    Join Date
    Dec 2014
    Location
    Iowa City, Iowa
    Posts
    801

    Re: CPP2 - Heating Element no longer heating

    Quote Originally Posted by xvelids View Post
    Thanks for your help. Somehow, the assembly itself shook loose and was not in the guides. I reset the fuse and it reheats fine now. Appreciate everyone's advice!
    You can pop that breaker washing the unit with hot tap water. I found that out one day.

  5. #5
    Cordless Bungee Jumper Sirius Glass's Avatar
    Join Date
    Aug 2010
    Location
    Southern California
    Posts
    1,110

    Re: CPP2 - Heating Element no longer heating

    Contact the Darkroom Doctor Dave Smith http://www.darkroomdoctor.com/ He and his wife Norma have helped me in the past.
    Nothing beats a great piece of glass!

    I leave the digital work for the urologists and proctologists.

Similar Threads

  1. Jobo CPP2 no longer heating
    By yelmarb in forum Darkroom: Equipment
    Replies: 4
    Last Post: 30-Jan-2019, 16:19
  2. Heating Pt/Pd solution before coating
    By Nasser in forum Darkroom: Film, Processing & Printing
    Replies: 5
    Last Post: 21-May-2013, 21:53
  3. LOOKING FOR MANUAL FOR JOBO CPP2 PROCESSOR - HAVE CPP2 Service Manual in PDF
    By Dan Boardman in forum Darkroom: Film, Processing & Printing
    Replies: 3
    Last Post: 29-Apr-2012, 18:12
  4. Jobo CPP heating element
    By Sean Galbraith in forum Darkroom: Film, Processing & Printing
    Replies: 1
    Last Post: 1-Feb-2010, 15:19
  5. Big Sink and good chem heating unit
    By bob carnie in forum Darkroom: Equipment
    Replies: 8
    Last Post: 20-Dec-2007, 15:43

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •