Quote Originally Posted by tgwilkinson View Post
Hi csbrk9. I got an Aztek Premiere running with DPL 8 on a 2013 Mac Pro with Windows 10 running in Parallels using the Ratoc SCSI to USB adapter that way I could just flick back and forth between the Mac OS and Windows without needing to reboot. I vaguely remember trying it in Bootcamp, but found Parallels better since it has a nice interface for determining which USB devices I wanted connected to the Windows OS and which ones I wanted to keep with my Mac OS, which might have helped me avoid device conflicts. Parallels basically pulled the mouse and keyboard over virtually, so the Ratoc adapter and sometimes an external drive were the only devices attached to the Windows OS.

I usually ran into problems if I didn't have the drum scanner fully booted up before I started Windows. If for some reason the drum scanner didn't appear in the drop down menu within DPL I could close DPL and open Device Manager, right-click on the name of my computer in device manager, and select Scan For Hardware Changes and the scanner would show. Then when I reopened DPL the scanner would be listed there as well. I was also running the Ratoc adapter without the included extension cable attached; I don't know if that made a difference. I never had to change anything with the registry or do anything fancy when I installed the drivers. The hardest part was figuring out the best way to install Windows. I also had nothing else installed on Windows 10 when I set up the scanner, so that probably also helped avoid device conflicts.

Those are the things that worked for me. But it sounds like you're getting a yellow triangle error next to the device in device manager. The build you're trying for is definitely possible, but it there's clearly a conflict somewhere. You've probably tried most of these things, but to troubleshoot you can try (1) try plugging it into a different port, it could be a problem with the bus the port is on and an allocation of shared resources there, (2) unplugging all other devices from the Mac and do a fresh install of Windows. Hopefully without any other devices attached there wouldn't be a conflict in resources, which is what the yellow triangle often means, (3) trying going through the same steps to set it up, but on a different Mac to see if the issue is the particular internals of the Mac you started with, (4) try installing Windows 10 through Parallels instead of Bootcamp to see if that gives you more control over what devices Windows 10 is seeing to cut down on sources of conflict.

I hope that helps!

Thank you so much for your generous response! Yes you are correct, we are getting the yellow triangle error. Just out of curiosity, what version of MacOS are you running? I'm wondering if that could be effecting it. I'm also trying to figure out the USB imlpementation in parallels and see if there is any trick there. For whatever reason, bootcamp detects the Ratoc/scanner with an error, but both Parallels and VMware don't even see/register them. I'm wondering if there is a trick to this in settings for parallels, like setting up a device or something. I've also sent our Ratoc over to Evan, he is going to test it in his setup and make sure it isn't a hardware issue.