Results 1 to 6 of 6

Thread: Ilfospeed 500 Controller Issues

  1. #1

    Join Date
    Feb 2012
    Location
    Lancaster, UK
    Posts
    5

    Ilfospeed 500 Controller Issues

    My De Vere 504's Ilfospeed controller works perfectly for about 30 minutes, then goes nuts, with the LED numbers flashing and the thing beeping at me. If I turn it off, it's fine after about twenty minutes. Is this an issue with the control pad? If it is, then I can replace it with the RH designs one. If not, is this a more serious (expensive) head issue?

  2. #2
    Jeff Bannow's Avatar
    Join Date
    Feb 2007
    Location
    Royal Oak, MI
    Posts
    259

    Re: Ilfospeed 500 Controller Issues

    Not sure about the problem, but I can highly recommend the RH Designs controller.

    Where are you located? Someone local might have one they could lend for testing.

  3. #3

    Join Date
    Aug 2010
    Location
    Nova Scotia, Canada
    Posts
    51

    Re: Ilfospeed 500 Controller Issues

    It could be the power supply as well. The DC power for the controller is in the power supply unit. I'd suspect it first. Could be a capacitor or voltage regulator breaking done, these things are getting on in years.

    George

  4. #4
    Ginette's Avatar
    Join Date
    Jul 2008
    Location
    Montréal suburb, Québec, Canada
    Posts
    460

    Re: Ilfospeed 500 Controller Issues

    As George said, it is probably the power supply. I have many keypads and check for a similar problem and all keypads do the same flicking LED with the faulty power supply and all keypads work with another power supply. Before buying a RH Designs controller, you should ask to another darkroom user near you for testing his power supply or find an used one.

  5. #5

    Join Date
    Jun 2008
    Location
    Melbourne, Australia
    Posts
    440

    Re: Ilfospeed 500 Controller Issues

    Sounds like something getting hot and breaking down electronically Maybe a dry solder joint?.
    Cheers Shane

  6. #6

    Join Date
    Feb 2012
    Location
    Lancaster, UK
    Posts
    5

    Re: Ilfospeed 500 Controller Issues

    Thanks for the good advice, I was concerned it was the head. Next thing, is there anyone in the north of England with a similar setup?!

Similar Threads

  1. Ilex Electronic Shutter & controller
    By saransk in forum Cameras & Camera Accessories
    Replies: 0
    Last Post: 21-Oct-2009, 11:16
  2. Ilford 500cpm Controller
    By cyrus in forum Darkroom: Equipment
    Replies: 0
    Last Post: 24-Jan-2007, 00:26

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •