View Full Version : Slo-Mo shutter

Dirk Rösler
21-Feb-2010, 05:04
Hi, I was given a lens in Seiko shutter which all looks dandy, but... the shutter blades move in slow motion. Times themselves seem to run OK, it's just you can watch the blades going in and out. Haven't shot with it to see what this would look like, perhaps I shouldn't bother fixing. :o

Previous owner said he tried some "maintenance". Any DIY fix to this? It's a freebie, professional attention not worth it... thanks!

Peter K
21-Feb-2010, 05:34
Dirk, you can try to clean the shutter blades, only the shutter blades, with a Q-tip and lighter-fluid. Avoid that any fluid enters the shutter itself.

Good luck,


21-Feb-2010, 06:04
What's the lens? Are you sure it's not worth shelling out $100 for so for a CLA? I had a little Fujinon 150mm W in a Seiko shutter. It was a sharp, compact lens.

Dirk Rösler
21-Feb-2010, 06:08
It's actually a 127/4.7 Mamiya Sekor for the Polaroid 600SE. These lenses are actually LF type lenses on a helicoid. I have removed the lens/shutter assembly from the helicoid already and mounted on a board. I really don't want to invest in it. Might be easier to find a #0 junker and use its shutter for it.

I think the previous owner may have already tried the lighter fluid trick, there is no sign that the lens was taken apart (until now ;)

21-Feb-2010, 06:10
It sounds like someone has tried to lubricate the shutter blades. That is never a good idea, as it makes them adhere to each other. I would think it is difficult to clean them properly without opening the shutter. If it is made in a similar way as most other shutters, nothing will fly out if you open it carefully. This would give you better access to the blades. Be careful so you don't push on the blades, and try to wipe off both sides (front and back). Good luck!
Svein L

David McNiven
21-Feb-2010, 08:43
Hi, removing the cover doesn't give access to the blades or the carrier. In fact this assembly is only accessed by removing everything else from the casing.
If it's the old Seikosha S shutter then I would probably look for a newer replacement.
You could try a bath in acetone or similar solvent with regular agitation and operation of the shutter but do it outside & wear gloves.
Not for minutes or hours though - a week might do it - I only ever tried it for a day or two. It was easier for me to strip & rebuild them, I was just experimenting!
Good luck.

21-Feb-2010, 18:26
Had the same problem/same shutter about 7-8 months ago. Gave it a three or four dunk bath/soak in one cup of naptha.... has worked perfectly since. Hope it continues ...Bill

Glenn Thoreson
21-Feb-2010, 18:37
Goopy shutter blades. Unscrew and remove the cells before doing anything. Naptha and Q-tips usually gets 'em going again. Done tons of them. It takes some concentrated effort to get it really clean, as the goo is hiding between them where it can be hard to see it. Do both sides with the blades at numerous positions. You should be able to control the opening size by holding back the cocking lever when you trip it. Don't be shy with it. It's no good to you the way it is. :D

Dirk Rösler
21-Feb-2010, 19:31
Thanks all - I have to find a substance here that does this cleaning, heaven knows what it is called in Japanese. Before I do though, I should take a picture with it and see what kind of image it produces.

21-Feb-2010, 19:58
They should sell Zippo lighter fluid in Japan Dirk, I remember my friend buying a Zippo while he was over there, from somewhere in Tokyo.

Dirk Rösler
21-Feb-2010, 20:18
Thanks, I think I can find this at the drug store or pharmacy (Zippo is a "premium brand" here).

Stupid question: after the soak do I dispose of the stuff (how?) or back into the bottle?

21-Feb-2010, 20:33
Burn it? The cans have a non (or difficult) removable top so it won't go back in. Could just pour it onto a bit of pavement to evaporate off too.

Michael Roberts
21-Feb-2010, 21:40
Dirk, I have tried lighter fluid and had disappointing results--it can be greasy; seems to work well when first applied, but the shutter can return to slow speeds or hanging up when the fluid dries. I have had much better luck with aerosol electronics cleaner (hexane, carbon dioxide, and ethanol). Radio Shack sells this. You might also find a similar product in other electronics stores. Just spray into the cable release socket, then cock and fire the shutter several times on each speed. Dries (evaporates) quickly and leaves no residue.

Dirk Rösler
21-Feb-2010, 23:46
Hello again, thanks for all the advice.

I found some instructions on applying Naphta to stuck shutters on a Japanese site and followed those, without a full soak. Now it is snappy and great, but as Michael says, I don't expect this to last. How long does this take to dry? It seems to evaporate quite quickly. Wonder when it is safe to tell "it worked"...

Before the fix I wanted to see what this lens does and this Sekor seems a really sharp piece of glass with enough coverage for 4x5. The attached was taken with the slow blades, interestingly, no discernible effect on the image (I expected edges to be darker), just impossible to know what speed you're setting. I suppose despite the slow shutter blades, the hole area will still get a uniform amount of exposure, which is probably as it should be, no matter the speed.

22-Feb-2010, 00:00
Lighter fluid probably wouldn't be very good for a straight soak, but as a fluid for wiping off oil/grease then it will work well, as with the wiping action you will be removing almost all of the lighter fluid, with the grease dissolved in it.

Peter K
22-Feb-2010, 10:31
Just spray into the cable release socket, then cock and fire the shutter several times on each speed. Dries (evaporates) quickly and leaves no residue.
And it also removes the lubrication for the bearings too. So the bearings will worn out and the shutter is destroyed completely.


Dirk Rösler
22-Feb-2010, 17:42
Thanks all, so far so good, shutter is running smoothly... but will it last? Off to ebay with it, quickly while it is in "mint" condition :p (just joking!!)