View Full Version : Problem with Prontor Professional 01 Shutter

Atul Mohidekar
9-Dec-2006, 23:19

I have a lens mounted in Prontor Professional 01 shutter. This is a self cocking shutter. You just open the aperture fully, put the shutter speed dial to "B" and then open the shutter for focusing with the cable release pushed and locked. The shutter should remain open as long as the shutter release stays locked. The problem is that the shutter is not staying open even if the shutter release cable is kept locked.

1. Has anyone faced this problem?
2. What might be the problem?
3. Is the shutter somehow damaged?
4. What might have damaged the shutter?

This shutter design allows usage of two shutter release cables, one for tripping the shutter and the other for keeping the shutter open for focusing. But I would rather use just one cable.


// Atul

Frank Petronio
10-Dec-2006, 05:41
You probably need a cable release with a longer "throw" to fully engage the mechanism. Gepe and others -- especially the German manufacturers -- make releases with longer throws than the Japanese releases, but you have to compare them in person or ask very specifically. Places where you can talk to a real person -- like Jim at http://www.mpex.com -- can get you the proper longer release.

Try using the second release -- I find it very nice to be able to check your focus quickly, for people photos -- I use two different sized and colored cable releases so I don't mix them up. I also have a Prontor remote control device on order. They are great shutters.

Atul Mohidekar
10-Dec-2006, 10:02
Hi Frank,

Thanks for the reply.

I'm not sure the longer throw is a problem. First, before reporting the problem here I had tried a couple of cables that (I think) had worked in the past. Second, the shutter release lever that is pushed by the cable (see #1 in the picture shown at SK Grimes' page: http://www.skgrimes.com/prontor/index.htm) stays down when the cable is pushed and locked. I will select the cable with the longest throw and report back.

// Atul

Atul Mohidekar
10-Dec-2006, 10:17
I just tried the lens with a cable with a very long throw. It did not work.

// Atul

Kirk Gittings
10-Dec-2006, 10:32
I have never had to buy a special "long throw" release for any of mine. Any sturdy release should work as long as it will handle the load. This is a problem that crops up with wear and must be repaired. It will happen every few years with heavy use. It is a simple fix but must be done by someone who is knowledgeable. Send it to grimes.

10-Dec-2006, 14:14

I'm in agreement with Kirk... sounds like you need to send it in for a good cla!


Atul Mohidekar
10-Dec-2006, 14:28
Thanks guys.

I suspected that this was a problem with the "B" setting and wanted to get confirmation/thoughts/suggestions from fellow users.

I'll send the lens for repair.

// Atul