View Full Version : Shutter wont cock

26-Jan-2006, 18:32
I received a commercial-astragon 210 lens today and *saw* it work over-and-over perfectly when the quy was telling me how to use it, but when I got home, cocked the shutter - fired it, then tried to cock it again IT DIDNT WORK! What on earth could be wrong? Is there some kind of trick with this crazy lens?

Michael Graves
26-Jan-2006, 19:13
What kind of shutter? On some of them, there is a preview button. If it is partially depressed, the shutter won't cock.

26-Jan-2006, 19:18
There is no name on the shutter, the only thing for identification is the lens (Commercial-Astragon 210mm). The preview button is slid all the way down. I've tried everything I know except for some type of special sequence. Geez - that sounds like it's a lock! :) I can take a picture of it for you if you email me jeremyrardin@gmail.com

27-Jan-2006, 09:34
Why not call the guy back and ask him? Better still, go back to the store and ask for another demo...

I would be careful with messing around with trying different things with the shutter since some of the older shutters were sequence-dependant, and you could damage the shutter if operations were done out of order.