PDA

View Full Version : Investigating the image orientation bug: feedback, please!



Oren Grad
13-Aug-2020, 14:04
We've gotten a number of reports about uploaded images being displayed sideways, for example in FS listings.

vBulletin has been reported to have trouble dealing with images uploaded from iPhones, because of the way the EXIF orientation tag is handled. A set of images that was reported to us today indeed had EXIF tags identifying an Apple device as the source. Can anyone else who has observed this problem with their upload(s) post here about what device was used to capture those images?

Thank you!

Dugan
13-Aug-2020, 16:01
I have uploaded photos with a Samsung G6, and had problems.
I have found that by editing the photos before uploading them, via cropping, solved the problem.
Unedited photos show up sideways or upside down.
I posted this workaround in an earlier complaint thread, but it got buried/overlooked.

BrianShaw
13-Aug-2020, 16:07
I don’t recall posting any iPhone pictures here but a bunch on another vBulletin-based forum. Always sideways unless I open the picture, edit, and save. Don’t seem to need to really edit. Just go through the motions and then they seem to post in correct orientation. If I do any edit it will be a crop.

Oren Grad
13-Aug-2020, 16:12
I have uploaded photos with a Samsung G6, and had problems.
I have found that by editing the photos before uploading them, via cropping, solved the problem.
Unedited photos show up sideways or upside down.
I posted this workaround in an earlier complaint thread, but it got buried/overlooked.

Thank you for re-posting it here!

Bernice Loui
13-Aug-2020, 17:01
Image file produced with Canon digital. Uploaded with Apple note book.
The problem some times does not occur if a single continuous words is used in the title. It a space or number or similar is present in the image file name, the system will force landscape orientation once the image file is posted.

This appears to happen with other forum web pages and eBay.



Bernice

Vaughn
13-Aug-2020, 18:46
I used an old photo I have stored on the Forum for a recent post -- and for the first time since it was posted in 2007 it went sideways. It is orientated the correct way in the thumbnail.

https://www.largeformatphotography.info/forum/showthread.php?154331-Backpack-for-Hiking-with-an-11x14-View-Camera&p=1564324&viewfull=1#post1564324

Might have been taken with a Canon Digital point and shoot.

Going back to some old posts that used the same image, they are all flipped now. Have not noticed it with any other of my images yet.

BrianShaw
13-Aug-2020, 19:44
Image:

206845

BrianShaw
13-Aug-2020, 19:46
After a tiny crop (medium size)

206847

BrianShaw
13-Aug-2020, 19:49
After a tiny crop (large size)

206848

Louis Pacilla
14-Aug-2020, 07:21
I found I had to flip the image in a photo edit app (not simply edit in the iPhone) then ((save)) it in it's new orientation and then it would be in the correct direction when I post it to the forum. Again if I simply flip it in the phone edit then try to post to forum it would be in it's wrong orientation again.