View Full Version : Trouble with Color Munki Photo

17-Feb-2013, 15:31
Hi - I'm having trouble with my Color Munki Photo, When I purchased it the software provided refused to recognise the Color Munki although the devices' LED lit up. After contacting X-rite they said that the device needed to be connected to a powered USB port. I tried all the USB ports on my machine and found one where the device worked. I calibrated the screen / printer and the paper I was using at the time and found it provided excellent results.

However on using the device a few days ago as I wanted to re-profile my screen and my new printer, I found that it was the same as when I purchased it - the device was not recognised by the software. I read the instructions again and was also advised by a friend to purchase a powered USB port, after purchasing a new, powered USB port the results where just the same... device not connected / recognised.

I tried the device on a very old laptop computer with no problem at all although the colour on the laptop was not the same as the desktop monitor. All my USB devices work fine on the desktop, I also disconnected all USB devices except for the keyboard / mouse, still no joy.

I wonder if I could profile my new printer using the laptop and transferring the profiles to the desktop although I realise that the screen colours will not be the same but I can match both screens together.

If anyone has any suggestions or can suggest a different device that will profile both screen and prints on paper I would be much obliged if you can post your thought here.

nn :)

Tyler Boley
17-Feb-2013, 17:09
yes you can certainly create printer profiles on one machine and transfer to another, that's how people like me make custom profiles for others, as well as here for the printers use that are driven by a PC, profiling software on a Mac...
Why there are device recognition problems I'm not sure. I'd continue to press Xrite for a solution, though from considerable experience I know how frustrating that can be...

Doug Fisher
18-Feb-2013, 09:48
If a USB port worked once and then the same port didn't work again later plus the munki works fine on other computers, it doesn't sound like an X-rite hardware issue but either a desktop computer hardware issue or operating system issue. Have you checked for updated usb drivers from the manufacturer of your motherboard? You have tried plugging into a USB port on the back of your desktop so that you know you are dealing with a USB port attached directly to the motherboard, right? Hubs often cause problems (and aware that any USB ports on cards in expansion slots can have the same problem as hub-based slots).


22-Feb-2013, 20:51
I ran into a similar problem.
It was on a newer Mac.
Go to system preferences.
You should find X Rite Devices under other

Milton Tierney
26-Feb-2013, 16:13
same problem, try reinstalling software