Results 1 to 8 of 8

Thread: Help with a Rittreck View 5x7 (lens board wont mount)

  1. #1

    Join Date
    Feb 2016
    Posts
    3

    Help with a Rittreck View 5x7 (lens board wont mount)

    Hello,

    I have a Rittreck that I've been slowly gearing up to use. I got the last needed piece recently in the form of a lens board. Although it's obvious it's the correct board I can't get it to mount on the camera. Unlike other cameras that have a slide, this one has a spring loaded pivoting catch up top. I place the board behind the thin metal plate at the bottom, lever it in and push the catch as far as it seems it should go, and the top of the board just doesn't quite clear the top of the catch, meaning it wont go in without perhaps forcing it. I'm not anxious to use force for fear of jamming the board, breaking the lens, or the camera. The catch itself doesn't pivot very far, maybe 15 degrees.

    Can any Rittreck users perhaps point me to the error of my ways before I can find a copy of the manual somewhere? Is there some magic trick to mounting the lens board? The groove at the bottom of the board does appear clean but I'm not convinced the board is going to the absolute bottom, and a millimeter less would be all the board needs to clear the latch.

    Thanks in advance everyone. This seems like a great camera and I'm really looking forward to using it.

  2. #2
    Randy Moe's Avatar
    Join Date
    Dec 2011
    Posts
    9,414

    Re: Help with a Rittreck View 5x7 (lens board wont mount)

    On mine there is a sliding lock with an arrow on the top right facing the lens. Slide it outwards.

  3. #3

    Join Date
    May 2010
    Location
    Kalamazoo, Michigan
    Posts
    136

    Re: Help with a Rittreck View 5x7 (lens board wont mount)

    Real Rittreck boards have a milled out area top and bottom. This makes it easier to fasten them in. Does yours have these? My Rittreck operates like yours.
    Click image for larger version. 

Name:	IMG_20180701_083112.jpg 
Views:	22 
Size:	34.1 KB 
ID:	180005

  4. #4

    Join Date
    Feb 2016
    Posts
    3

    Re: Help with a Rittreck View 5x7 (lens board wont mount)

    Interesting... My lens board looks nothing like that in the details. It's done in sea-foam enamel cracked with age similar to the camera, is the right size, and has a circular light seal in the right place and size on the back. It looks factory original. But it does not have those milled areas, only a bit of beveling on the edges to take off the hard edges. Looking online the camera seems more grey so I'll check the color, but it really does seem like its the right board. Perhaps Rittreck modified the design over the years? Anyhow, it seems I'm not doing anything wrong mounting the board. Looks like its time to get out a metal file. Thanks much!

  5. #5

    Join Date
    Sep 1998
    Location
    Oregon and Austria
    Posts
    2,039

    Re: Help with a Rittreck View 5x7 (lens board wont mount)

    Quote Originally Posted by J_3 View Post
    Interesting... . Looks like its time to get out a metal file...
    That would be my recommendation if there's just a bit of interference. Really, all the lensboard has to do is hold the lens in place and keep light out. Just make sure you file the minimum necessary to do the job.

    Doremus

  6. #6
    Randy Moe's Avatar
    Join Date
    Dec 2011
    Posts
    9,414

    Re: Help with a Rittreck View 5x7 (lens board wont mount)

    IMG-1211 by TIN CAN COLLEGE, on Flickr

    IMG-1210 by TIN CAN COLLEGE, on Flickr

    IMG-1208 by TIN CAN COLLEGE, on Flickr

  7. #7

    Join Date
    Feb 2016
    Posts
    3

    Re: Help with a Rittreck View 5x7 (lens board wont mount)

    Perfect and thank you ! ! ! The difference between my Rittreck and yours is there is no arrow on my front standard, and the slide is metal and much more flush with the top of the camera. Without looking very close it looks like an immovable piece that's just bolted directly into standard to guide the catch. However, it slides just like yours does, and when it's slid away from the catch it frees it enough to easily clear the board. So it's a safety lock. From your previous description, I'd thought you had one of the lens-board converters or perhaps a substantially different model than I had. The pictures solved the issue for me. Thanks so much !

  8. #8
    Randy Moe's Avatar
    Join Date
    Dec 2011
    Posts
    9,414

    Re: Help with a Rittreck View 5x7 (lens board wont mount)

    .

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •