Results 1 to 3 of 3

Thread: Durst 1200 Elite 2000 computerised autofocus system Big Problem, please HELP

  1. #1

    Join Date
    Dec 2011
    Posts
    10

    Durst 1200 Elite 2000 computerised autofocus system Big Problem, please HELP

    Hello everyone, i am writing in short my problem,
    My Elite 2000 unit does not lighten up, neither it respond on buttons pushing.
    Only the Expose button green light appears after powering the unit, but
    that is all.
    I am desperate as i have quite an important print session today,
    any idea what is happening and how to proceed?

    Thanks in advance!

  2. #2

    Join Date
    May 2007
    Location
    New York City & Pontremoli, Italy
    Posts
    657

    Re: Durst 1200 Elite 2000 computerised autofocus system Big Problem, please HELP

    I suppose you've checked to see if the lamp is blown and needs to be replaced.
    Also check to see if the lamp socket receives power - you need to know how to do this properly and safely.
    Hopefully, there will be more substantive suggestions.

  3. #3

    Join Date
    Dec 2004
    Location
    Netherlands
    Posts
    253

    Re: Durst 1200 Elite 2000 computerised autofocus system Big Problem, please HELP

    With the unit off. Press the enter key. Power on.
    All leds and the displays go on for 1.5 sec.
    If not you are toast.
    If they went on you can now manual control the unit. As temporary solution.

Similar Threads

  1. Durst Pictograph head (durst 1200)
    By Giorgio23 in forum Darkroom: Equipment
    Replies: 0
    Last Post: 25-Dec-2010, 10:30
  2. Durst ELITE 2000
    By fix_se in forum Darkroom: Equipment
    Replies: 2
    Last Post: 5-Jul-2010, 14:32
  3. problem of the Linhof MT 2000
    By Yong-ran Zhu in forum Cameras & Camera Accessories
    Replies: 4
    Last Post: 12-Apr-2007, 14:10

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •