Results 1 to 3 of 3

Thread: Zone VI cold light -- HELP needed

  1. #1

    Join Date
    Apr 2015
    Location
    Purcellville, VA
    Posts
    91

    Zone VI cold light -- HELP needed

    What would we do without this forum! I searched some old posts and know there will be someone who can help.

    In the process of preparing my darkroom for work after more than a decade's sitting quietly (the equipment, not I), today I turned on my D2 enlarger -- with Zone VI 4x5 cold light (the round one) and compensating timer -- to inspect alignment at the easel. The lgith wasn't on for more than about 10 minutes. As I was doing some other things afterward over another 10 minutes or so, I started smelling something strange, which became a sort of burning smell, which I traced to the head, which was hot, though by no means too hot to handle comfortably. I unplugged it and removed it from the enlarger. Definitely a burning -- or worn out ballast? -- smell. I recall ballasts going bad in school rooms of my youth and having a burning sort of smell.

    (I had not plugged in the heater, though I don't believe that would be important; am I wrong?)

    Looking the unit over, I noticed that the casing of the cables is dry and cracked in a couple of small places, something I'd like to take care of anyway, but repairing the unit's main function is first. I wouldn't know a ballast from a beach ball. Does it sound like something a electrical/electronic-savy friend could do with standard parts? Anyone know what they would be? It would be great not to have to ship it somewhere ($$$).

    The lamp and timer appear to be working fine.
    Ulophot

    Sine scientia ars nihil est.

  2. #2

    Join Date
    Jan 2013
    Location
    Madisonville, LA
    Posts
    1,352

    Re: Zone VI cold light -- HELP needed

    Aristo (Zone VI) cold-light heads for that enlarger are pretty reasonable used or at auction. There's one on right now. You could also remove the sensor off that head and install it in another one if it didn't have one. Might be easier than replacing the cabling. Just a thought. L

  3. #3

    Join Date
    Apr 2006
    Posts
    372

    Re: Zone VI cold light -- HELP needed

    I recall replacing a capacitor in my Aristo D2 years ago. The details are long gone but it's still working fine. You might get your friend to check this out. If the ballast is bad I agree with the advice to find a replacement. That size is pretty common. You can probably find the sensor installation instructions online.

Similar Threads

  1. Replies: 13
    Last Post: 29-Jan-2004, 14:32
  2. Zone VI cold light
    By d.s. in forum Darkroom: Film, Processing & Printing
    Replies: 17
    Last Post: 8-Nov-2003, 15:11

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •