Results 1 to 7 of 7

Thread: Epson V700 problems

  1. #1

    Join Date
    Feb 1999
    Posts
    552

    Epson V700 problems

    Hi folks -- my Epson V700 has stopped working. There's a dim light burning in there, but it looks the main, bright scanning light went out. And in the Epson Scan window, in Professional Mode, there's no longer any option to select "film with holder" or any of the other options I'm used to seeing. It just says "Reflective" and "Film" and it won't let me select film. Any advice other than shipping it to Epson for repair? I'm bummed.

  2. #2
    Jon Shiu's Avatar
    Join Date
    Nov 2003
    Location
    Elk, California
    Posts
    1,266

    Re: Epson V700 problems

    Maybe check the cord that goes from the lid to the scanner is plugged in well.
    my black and white photos of the Mendocino Coast: www.jonshiu.com

  3. #3

    Join Date
    Jul 2016
    Posts
    2,098

    Re: Epson V700 problems

    Beyond the cord you can see here page 9 https://itg.beckman.illinois.edu/vis...s/prv7phpg.pdf

    "Reading scanner light" section.

    I shows what happens when lamp fails...

  4. #4

    Join Date
    Feb 1999
    Posts
    552

    Re: Epson V700 problems

    Jon -- you're a genius. It was the cord from the lid to the scanner. Somehow, it became almost completely unplugged. I should have checked all connections before going into a blind panic and posting on the forum. Pere, thank you for that link, too.

  5. #5

    Join Date
    Jun 2006
    Posts
    255

    Re: Epson V700 problems

    You have to love simple repairs!

    Just for future reference for people who find this thread and the bulb on their scanner is actually burned out, the following company has been able to provide replacement bulbs in the past:

    http://www.replacementlightbulbs.com/

    Doug
    www.BetterScanning.com

  6. #6
    Guilherme Maranhão coisasdavida's Avatar
    Join Date
    Apr 2012
    Location
    São Paulo, Brazil
    Posts
    332

    Re: Epson V700 problems

    I was able to get a replacement bulb for my V700 from another scanner. They are all almost the same.
    The was a surplus store here in São Paulo that sold scanners for $5. They had a bunch of them cracked open, I took a look and found one in which the bulb had similar lengths of wire to the V700 (one very long wire from one side, a very short wire from the other).
    Found one with a bulb with little darkening at the end and it was perfect.

  7. #7
    jp's Avatar
    Join Date
    May 2009
    Location
    Maine
    Posts
    4,710

    Re: Epson V700 problems

    Quote Originally Posted by Jon Shiu View Post
    Maybe check the cord that goes from the lid to the scanner is plugged in well.
    This comes loose every few months for me... I think it works loose from opening and closing the lid.

Similar Threads

  1. Problems with V700 holder used in V800
    By Drzeto in forum Digital Processing
    Replies: 2
    Last Post: 13-Nov-2016, 13:32
  2. Epson V700 - dumb question - betterscanning/epson holders
    By Meekyman in forum Digital Processing
    Replies: 10
    Last Post: 16-Feb-2014, 13:47
  3. Problems with silverfast and Epson V700
    By Songyun in forum Digital Processing
    Replies: 6
    Last Post: 28-Sep-2006, 22:42

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •