View Full Version : JOBO Process Timer 4

28-Jun-2017, 21:40
I just acquired a JOBO Process Timer 4.
I have tried every combination of button pushing I can think of to get it to work.

Here is some of what I have tried:
1.) On the minute side of the timer I have set all the dials to zero for all 4 steps.
2.) On the seconds side of the timer I have set the dial for step 1 to 5 seconds. Step 2 to 10 seconds, step 3 to 15 seconds and step 4 to 20 seconds.
3.) With the timer power switch set to on, I pressed the start button and the display lights up for step 1 and I press the recall button. I wait 5 seconds and nothing. No numbers in the display and no beeping to alert me that time is up.
4.) Repeat the same for remaining steps and I get the same results.

I have tried other combinations like pressing the start button and the recall button at the same time to see if that works and same result.

I have tried quickly pressing the start button twice, and the same result.

This timer can’t be that complex to operate but apparently this old guy can’t figure it out.

If someone would enlighten me I would greatly appreciate it.


Phil Hudson
3-Jul-2017, 12:17
On the similar "Timer 8" you input the desired time for each program in mins and secs. Hitting the red bar at the bottom once starts the countdown (not a digital display on the Timer 4 so wait for beep?). Hit bar again to stop beep. Automatically progresses to next time (ie step/program 2). Green reset button starts timing again at the beginning of step/program 1.

Apologies if I have mis-remembered or if the Timer 4 is way different from the Timer 8 with digital display.

3-Jul-2017, 20:15
Thank you for the information.

I will try it and see what happens.