View Full Version : Shift is very stiff on my new (to me) Rittreck view 5x7

Paul Kinzer
11-May-2017, 18:53
I got this camera last week, and like it very much. It's pretty big and heavy, but it has all the movements I think I'll need, feels very sturdy, and folds into a nice, compact size for traveling.

It does need some work. The bellows are deteriorated to the point of being slightly crumbly; not good for clean film! I also will want to replace the 4x5 back that came with it with a Universal back that will allow the use of my 6x12 back. Both of those are things I'll figure out.

But this post is about the very stiff shift function on the rear of the camera. I'll figure it out if I must, but if someone knows of the best way to loosen it up, I'd be grateful to hear it. I already got all the other movements to go as smoothly as I like, but have not yet figured out how to clean up the old lubricant, loosen whatever is too tight, or lubricate whatever it must be that is making this pretty much unusable in its current state. I'm not sure which of those, if any, is the issue.

Thanks in advance!

Chauncey Walden
12-May-2017, 15:13
Paul, do you have the manual? If you don't, I can email you a PDF. Just send me a PM with your email id.

Paul Kinzer
12-May-2017, 16:29
PM Sent!

Paul Kinzer
16-May-2017, 22:26
I'd still like to know if anyone has experience freeing up the rear shift on a 5x7 Rittreck View. I've got the manual now (thanks!) and it's helped with the functions, but the shift is too stiff to use as it is. I don't want to risk harming it, but will have to unless someone has some ideas. I'm pretty handy, so will probably figure it out...

16-May-2017, 23:28
Try to undo the locks and see if you can get it a little apart... Sometimes moisture in the air can be forced between sliding surfaces (due to air pressure) and can build up corrosion and even calcium deposits even on a dry camera... Polish these with a good metal cleaner and silicone grease lube...

Check sliding surfaces with a small straight edge to see if they are truly flat, as they might be tweaked or a wave in the material that's causing binding... Then it might require removal and hammering it flat on a flat surface carefully...

Poke around and see what you might find...

Steve K

Paul Kinzer
17-May-2017, 19:07
Thanks, Steve. I did try most of what you suggested, with little luck. I cannot get at most of the area where the metal meets, even after loosening the knobs. But where I can expose the metal I do see some corrosion, and think that's the issue. I cannot figure out the best way -- or any way, frankly -- to disassemble the back to get at the unexposed bits. I think I see what might work, but will need to get proper tools. If no one has any further advice at this point, I'll try to post some photos this weekend, showing what I think I need to do to get it apart. Maybe someone will stop me if my ideas are wrong-headed!