View Full Version : Epson 3880 custom paper sizes, prints resized small

1-Jun-2015, 13:07

I hope some can help as I'm tearing my hair out with this.

I am printing with an Epson 3880, Mac OS Yosemite 10.10.1.

I have set up custom paper sizes of 432mm (17 inch) x 710 mm. I'm trying to print an image 15in x23 on this paper, but no matter what, the printed image is much smaller than it should be. The print is coming out 2/3rd the size it should be. I've tried in Lightroom, Photoshop CS5 and Aperture. I have checked and double checked absolutely everything. Uninstalled the drivers, reset the printers in OSX and still no joy. Searched high and low without success. Attached are screenshots of the settings which look correct.

Can anyone help? Thanks.


neil poulsen
2-Jun-2015, 05:39
With all the different programs you've tried, it sounds like the print driver. (?) I've had problems printing custom print sizes on Epson printers, i.e. Epson drivers, before. I'll bet a good RIP would do it. But that's an expensive solution, and there tends to be a heavy learning curve.

For example, perhaps you could find and download a trial version that's free for a period of time. Note that ColorBurst Overdrive software prints through the driver, whereas other RIPs sidestep the driver.

I noticed in the instruction manual that they offer non-custom print sizes like A2 (16.5"x23.4") and 40cmX60cm (15.5"x23.6"). You might try one of these sizes and turn off paper size checking using the 3880's panel.

You could also try printing through a different feeder. Like, one of the rear feeders?

Sometimes software likes to be tricked by being fed something that it has an easier time recognizing.

2-Jun-2015, 07:52
Everything I've seen for the 3880 say maximum printable area and cut paper size is 17x22 inches, so I'm not sure you can trick the printer to go beyond that size without it doing something odd, like you have experienced.

2-Jun-2015, 15:23

Thanks for the reply Neil. I've figured it out so this is for anyone else experiencing the same problem this is the fix below. It only happens on 17inch wide papers custom size and other issues with fibre/thick papers. Just to confirm, the driver is ok and I've printed on custom sizes no bother before. For some reason, it started playing up in the last few days.

The 3880 will print up to 17x37.5in as standard with the Epson driver and I've printed lots of 37inch panos on this printer. The Epson driver doesn't support borderless printing on custom sizes though, and this gave me a clue. Custom paper sizes on OSX 10.6.x need a minimum margin of 0.2in otherwise when sending data to the printer, there is some arithmetic at work that fools the printer into printing the output small, or part of the image missing. I set all the margins to this and it part fixed the issue but print output was only slightly smaller. I then got a windows machine and tried this with the same results. This suggested the printer may be the cause so I looked at the LCD menu settings.

The 3880 has a setting buried within on the printer's LCD control panel called "Paper size check". If this is set to "on" as it was on my printer, it seems to conflict with some papers, margin settings and custom paper sizes. In my case it is Brilliant Museum Satin Matte White 17inch wide (truly outstandng paper incidentally). It was being thrown out or fed through, and on the occasions it did feed properly, the image was printed small or part missing. I went through the LCD settings and turned the paper size check to "off" and this fixed the issue. I've managed to print of seveal images this evening on the custom paper sizes at the correct size. I'm not sure why it was set to on, maybe I accidentally set it to on when I was pressing the buttons to feed the paper through to clear an error or something.*

*Edit: To print borderless on standard paper sizes (which I was doing a few days ago), the software driver tells you to set the paper check size to "on". This explains why.

So, the solution is "when using custom paper sizes" to set paper check size via the printer's LCD to"off". Press menu, scroll through the settings and set as per the menu.

As an aside, I did a few searches this evening and found plenty threads where folk have had the same problem but haven't found a fix yet. One thread over at photo net has the same issue that was solved, that was the same fix as I found out. Looks like Epson TS were struggling and about to send the guy a new printer. Link to the thread http://photo.net/digital-darkroom-forum/00Z2F7

Hope this is helpful to anyone else experiencing the same problem.